Firefox 3.6, broken web developer toolbar

Thursday, July 15, 2010 by Netforge

Quick little trick for other web developers who use the handy Web Developer add-on, which won’t install once upgrading to Firefox 3.6.x

Use this at your own risk (working great for me however):

  1. On the download page above, right-click and download the .xpi file somewhere onto your computer (doesn’t matter where).
  2. Change the .xpi extension to .zip – and extract the files inside (the xpi packages are just zip archives).
  3. You’ll now see a bunch of files, open up install.rdf in any text editor.
  4. Replace
    <em:maxVersion>3.5.*</em:maxVersion>
    with
    <em:maxVersion>3.6.*</em:maxVersion>
  5. Save your changes to the file, and then just rezip ALL of the files up into a new zip file.
  6. Change the extension back to .xpi, and drag ‘n drop onto Firefox.

Share Via:

Share on Facebook Share on Twitter




Comments:

    Be the first to comment!

Add a Comment:








Netforge Twitter Feed

@netforge_au

@netforge_au


@netforge_au


@netforge_au


@netforge_au



Keep Up To Date Facebook Twitter Netforge Blog








Copyright © 2017 Netforge (Australia).     Address: 84 Halifax Street, Adelaide SA.     Phone: (08) 8121 4621     Email: inquiries@netforge.com.au     ABN: 30 769 018 561